Security Alert: System Updates Required

June 6, 2016

At ABC, securing your member data is one of our foremost priorities.  While keeping security measures in place is an ever-evolving process, one of the more immediate changes needed is to the platforms by which we exchange data.  What this means is older browsers and operating systems that don’t support current security protocols will need to be upgraded.  We have provided links below that will allow you to upgrade your OS and Browsers to the minimum requirements.

Minimum Requirements will need to be:

  • Windows 7 Operating System or greater
  • Internet Explorer 11 or greater
  • Chrome 30 or greater
  • Safari 7 or greater
  • Safari Mobile Browser 5.6 or greater
  • Android Browser  5.0 or greater


ABC’s scheduled deadline for customer upgrades to be complete is October 1, 2016. Computers that have not been upgraded by this date will find ABC’s systems inaccessible, so as to ensure the safety and security of your data. If you are currently using Windows XP or Vista operating systems, ABC will be proactively working with you to ensure upgrades are done before the required completion date. Please contact us with any questions, or for assistance with your upgrade. Thank you for working with us on these steps toward the future!